Author Topic: - - SA-MP not working? Read here first. - -  (Read 3283 times)

0 Members and 1 Guest are viewing this topic.

Offline Wes

  • Hero Member
  • *****
  • Posts: 2870
    • View Profile
- - SA-MP not working? Read here first. - -
« on: February 20, 2009, 01:19:24 am »
There have been a lot of threads concerning SA-MP not working, their game freezing while loading and not being able to connect to a server. It is usually the same type of problem causing this to occur, so I will list the most common 'fixes' for this problem below.

Help! My SA-MP doesn't work. What do I do first?
  • Check if the server you're trying to connect to, is displayed on your SA-MP client.
  • Check your firewall's settings to see if it allows SA-MP.
  • Check your SA-MP's registry ('regedit' in Run) to see if the path to gta_sa.exe is correct.
  • Check if you are running the game as Administrator.
  • Check if the single player works.
  • Update your graphic card's drivers.
  • Make sure you have the latest sa-mp client

All of this seems to be fine, but my game still doesn't work. How can I get my game to work?
  • Remove any modifications if you have these installed. SA-MP does not support mods!
  • Remove d3d9.dll from your base GTA-folder.
  • Remove gta_sa.set from your GTA San Andreas User Files.

Most of these solutions will fix your game, however it's of no certainty that your game has to work after following this list. A fresh and clean install of both SA-MP and GTA:SA can do wonders as well.

If you're having another problem, click this link for a list of the most common SA-MP problems and how to get rid of them. If none of this worked, please do not hesitate posting a new thread.
« Last Edit: February 13, 2012, 12:40:23 pm by Shadow_Pot »
Thoughts roll down the shaft of the brain, mental gives the signal to the physical